// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+(,\d+)*)$").unwrap();
let string = "# Inválido
,12312.*
123,12312,,12312312
asdasd,123123,12312
1,3123,asadas,123123
12312,12312312,312312,1,3,
,abc,321
# Válido
12312,12312312,312312,1,3
1,2,3
999,999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}