import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+(,\\d+)*)$";
final String string = "# Inválido\n"
+ ",12312.*\n"
+ "123,12312,,12312312\n"
+ "asdasd,123123,12312\n"
+ "1,3123,asadas,123123\n"
+ "12312,12312312,312312,1,3,\n"
+ ",abc,321\n\n"
+ "# Válido\n"
+ "12312,12312312,312312,1,3\n"
+ "1,2,3\n"
+ "999,999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}