# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)((?:Rs|EURO|DNR)\s*)\d+/\g<1>100/g;t' <<< "0 RS 125 | password1
1 EURO 25 | password2
2 DNR 30 | password3"