using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)((?:Rs|EURO|DNR)\s*)\d+";
string substitution = @"\g<1>100";
string input = @"0 RS 125 | password1
1 EURO 25 | password2
2 DNR 30 | password3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}