import re
regex = re.compile(r"(?i)((?:Rs|EURO|DNR)\s*)\d+")
test_str = ("0 RS 125 | password1\n"
"1 EURO 25 | password2\n"
"2 DNR 30 | password3")
subst = "\\g<1>100"
result = regex.sub(subst, test_str)
if result:
print(result)