use strict;
my $str = '0 RS 125 | password1
1 EURO 25 | password2
2 DNR 30 | password3';
my $regex = qr/(?i)((?:Rs|EURO|DNR)\s*)\d+/p;
my $subst = '\\g<1>100';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";