re = /(?i)((?:Rs|EURO|DNR)\s*)\d+/
str = '0 RS 125 | password1
1 EURO 25 | password2
2 DNR 30 | password3'
subst = '\\g<1>100'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result