using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\r?\n[^\S\r\n]*[([].+[)\]](?:\r?\n(?![^\S\r\n]*[\[\]()]).*)*\r?\n[^\S\r\n]*[\{(].+\n";
string substitution = @"";
string input = @"speaker1: hello
speaker2: hello (clears throat), let me show you something Ted Cruz said last week
(begin audio clip)
Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?
(end audio clip)
speaker1: now isn't that interesting";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}