const regex = new RegExp('\\r?\\n[^\\S\\r\\n]*[([].+[)\\]](?:\\r?\\n(?![^\\S\\r\\n]*[\\[\\]()]).*)*\\r?\\n[^\\S\\r\\n]*[\\{(].+\\n', 'gm')
const str = `speaker1: hello
speaker2: hello (clears throat), let me show you something Ted Cruz said last week
(begin audio clip)
Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?
(end audio clip)
speaker1: now isn't that interesting`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);