import re
regex = re.compile(r"\r?\n[^\S\r\n]*[([].+[)\]](?:\r?\n(?![^\S\r\n]*[\[\]()]).*)*\r?\n[^\S\r\n]*[\{(].+\n", flags=re.MULTILINE)
test_str = ("speaker1: hello\n\n"
" speaker2: hello (clears throat), let me show you something Ted Cruz said last week\n\n"
" (begin audio clip)\n\n"
" Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?\n\n"
" (end audio clip)\n\n"
" speaker1: now isn't that interesting")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)