use strict;
my $str = 'speaker1: hello
speaker2: hello (clears throat), let me show you something Ted Cruz said last week
(begin audio clip)
Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?
(end audio clip)
speaker1: now isn\'t that interesting';
my $regex = qr/\r?\n[^\S\r\n]*[([].+[)\]](?:\r?\n(?![^\S\r\n]*[\[\]()]).*)*\r?\n[^\S\r\n]*[\{(].+\n/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";