using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]+).*|.";
string substitution = @"\1";
string input = @"foo 12 bar 34";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}