$re = '/([0-9]+).*|./';
$str = 'foo 12 bar 34';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;