const regex = /([0-9]+).*|./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]+).*|.', 'g')
const str = `foo 12 bar 34`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);