use strict;
my $str = 'foo 12 bar 34';
my $regex = qr/([0-9]+).*|./p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";