package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]+).*|.`)
var str = `foo 12 bar 34`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}