import Foundation
let pattern = #"([0-9]+).*|."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"foo 12 bar 34"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)