# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d:\d+):\d+$/\1/gm;t' <<< "WBU-ARGU*06:03:04
WBU-ARDU*08:01:01
WBU-ARFU*11:03:05
WBU-ARFU*03:456"