const regex = /(\d:\d+):\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d:\\d+):\\d+$', 'gm')
const str = `WBU-ARGU*06:03:04
WBU-ARDU*08:01:01
WBU-ARFU*11:03:05
WBU-ARFU*03:456`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);