re = /(\d:\d+):\d+$/m
str = 'WBU-ARGU*06:03:04
WBU-ARDU*08:01:01
WBU-ARFU*11:03:05
WBU-ARFU*03:456'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result