# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d:\d+):\d+$"
test_str = ("WBU-ARGU*06:03:04\n"
"WBU-ARDU*08:01:01\n"
"WBU-ARFU*11:03:05\n"
"WBU-ARFU*03:456")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.