#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d:\d+):\d+$"
Local $sString = "WBU-ARGU*06:03:04" & @CRLF & _
"WBU-ARDU*08:01:01" & @CRLF & _
"WBU-ARFU*11:03:05" & @CRLF & _
"WBU-ARFU*03:456"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)