#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*\d+[.,]\d+"
Local $sString = "Mazda 6 2.0 Skyactiv-G Wagon 2018 - Startstop.sk - TEST" & @CRLF & _
"Mercedes C63 AMG Sound REVVING 6,3l V8 "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)