const regex = /\s*\d+[.,]\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\d+[.,]\\d+', 'gm')
const str = `Mazda 6 2.0 Skyactiv-G Wagon 2018 - Startstop.sk - TEST
Mercedes C63 AMG Sound REVVING 6,3l V8 `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);