import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\\d+[.,]\\d+";
final String string = "Mazda 6 2.0 Skyactiv-G Wagon 2018 - Startstop.sk - TEST\n"
+ "Mercedes C63 AMG Sound REVVING 6,3l V8 ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}