import re
regex = re.compile(r"\s*\d+[.,]\d+", flags=re.MULTILINE)
test_str = ("Mazda 6 2.0 Skyactiv-G Wagon 2018 - Startstop.sk - TEST\n"
"Mercedes C63 AMG Sound REVVING 6,3l V8 ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)