#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)['"](Text [\d]+)["']"
Local $sString = "case 'cryptocurrencies':" & @CRLF & _
" return this.$t('Text 1', { company: this.$global.company, num: this.$global.companyAge });" & @CRLF & _
" case 'currencies':" & @CRLF & _
" return this.$t(" & @CRLF & _
" 'Text 2'," & @CRLF & _
" {" & @CRLF & _
" company: this.$global.company," & @CRLF & _
" num: this.$global.companyAge" & @CRLF & _
" }" & @CRLF & _
" );" & @CRLF & _
"${ this.$t("Text 3", { company: this.$global.company }) } ${ this.$t("Text 4", { num: this.bonus }) }" & @CRLF & _
"${ this.$t('Text 3', { company: this.$global.company }) } ${ this.$t('Text 4', { num: this.bonus }) }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")