import Foundation
let pattern = #"['"](Text [\d]+)["']"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
case 'cryptocurrencies':
return this.$t('Text 1', { company: this.$global.company, num: this.$global.companyAge });
case 'currencies':
return this.$t(
'Text 2',
{
company: this.$global.company,
num: this.$global.companyAge
}
);
${ this.$t("Text 3", { company: this.$global.company }) } ${ this.$t("Text 4", { num: this.bonus }) }
${ this.$t('Text 3', { company: this.$global.company }) } ${ this.$t('Text 4', { num: this.bonus }) }
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)