import re
regex = re.compile(r"['\"](Text [\d]+)[\"']", flags=re.MULTILINE)
test_str = ("case 'cryptocurrencies':\n"
" return this.$t('Text 1', { company: this.$global.company, num: this.$global.companyAge });\n"
" case 'currencies':\n"
" return this.$t(\n"
" 'Text 2',\n"
" {\n"
" company: this.$global.company,\n"
" num: this.$global.companyAge\n"
" }\n"
" );\n"
"${ this.$t(\"Text 3\", { company: this.$global.company }) } ${ this.$t(\"Text 4\", { num: this.bonus }) }\n"
"${ this.$t('Text 3', { company: this.$global.company }) } ${ this.$t('Text 4', { num: this.bonus }) }")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")