$re = '/[\'"](Text [\d]+)["\']/m';
$str = 'case \'cryptocurrencies\':
return this.$t(\'Text 1\', { company: this.$global.company, num: this.$global.companyAge });
case \'currencies\':
return this.$t(
\'Text 2\',
{
company: this.$global.company,
num: this.$global.companyAge
}
);
${ this.$t("Text 3", { company: this.$global.company }) } ${ this.$t("Text 4", { num: this.bonus }) }
${ this.$t(\'Text 3\', { company: this.$global.company }) } ${ this.$t(\'Text 4\', { num: this.bonus }) }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);