package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)['"](Text [\d]+)["']`)
var str = `case 'cryptocurrencies':
return this.$t('Text 1', { company: this.$global.company, num: this.$global.companyAge });
case 'currencies':
return this.$t(
'Text 2',
{
company: this.$global.company,
num: this.$global.companyAge
}
);
${ this.$t("Text 3", { company: this.$global.company }) } ${ this.$t("Text 4", { num: this.bonus }) }
${ this.$t('Text 3', { company: this.$global.company }) } ${ this.$t('Text 4', { num: this.bonus }) }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}