#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)<SW-VARIABLE>\s*<SHORT-NAME>([^<]*)</SHORT-NAME>.*<SW-ARRAYSIZE>\s*<VF>([^<]*)</VF>\s*</SW-ARRAYSIZE>.*?<(?:/(?!<SW-VARIABLE>)[^/]*?)SW-VARIABLE>"
Local $sString = " <SW-VARIABLE>" & @CRLF & _
" <SHORT-NAME>abc</SHORT-NAME>" & @CRLF & _
" <CATEGORY>VALUE</CATEGORY>" & @CRLF & _
" <SW-ARRAYSIZE>" & @CRLF & _
" <VF>4</VF>" & @CRLF & _
" </SW-ARRAYSIZE>" & @CRLF & _
" <SW-DATA-DEF-PROPS>" & @CRLF & _
" cde" & @CRLF & _
" </SW-DATA-DEF-PROPS>" & @CRLF & _
" </SW-VARIABLE>" & @CRLF & _
"" & @CRLF & _
" <SW-VARIABLE>" & @CRLF & _
" <SHORT-NAME>def</SHORT-NAME>" & @CRLF & _
" <CATEGORY>VALUE</CATEGORY>" & @CRLF & _
" <SW-ARRAYSIZE>" & @CRLF & _
" <VF>8</VF>" & @CRLF & _
" </SW-ARRAYSIZE>" & @CRLF & _
" <SW-DATA-DEF-PROPS>" & @CRLF & _
" <HELLO>dsfadsf </HELLO>" & @CRLF & _
" <NO>itis</NO>" & @CRLF & _
" </SW-DATA-DEF-PROPS>" & @CRLF & _
" </SW-VARIABLE>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")