import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<SW-VARIABLE>\\s*<SHORT-NAME>([^<]*)</SHORT-NAME>.*<SW-ARRAYSIZE>\\s*<VF>([^<]*)</VF>\\s*</SW-ARRAYSIZE>.*?<(?:/(?!<SW-VARIABLE>)[^/]*?)SW-VARIABLE>";
final String string = " <SW-VARIABLE>\n"
+ " <SHORT-NAME>abc</SHORT-NAME>\n"
+ " <CATEGORY>VALUE</CATEGORY>\n"
+ " <SW-ARRAYSIZE>\n"
+ " <VF>4</VF>\n"
+ " </SW-ARRAYSIZE>\n"
+ " <SW-DATA-DEF-PROPS>\n"
+ " cde\n"
+ " </SW-DATA-DEF-PROPS>\n"
+ " </SW-VARIABLE>\n\n"
+ " <SW-VARIABLE>\n"
+ " <SHORT-NAME>def</SHORT-NAME>\n"
+ " <CATEGORY>VALUE</CATEGORY>\n"
+ " <SW-ARRAYSIZE>\n"
+ " <VF>8</VF>\n"
+ " </SW-ARRAYSIZE>\n"
+ " <SW-DATA-DEF-PROPS>\n"
+ " <HELLO>dsfadsf </HELLO>\n"
+ " <NO>itis</NO>\n"
+ " </SW-DATA-DEF-PROPS>\n"
+ " </SW-VARIABLE>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}