import Foundation
let pattern = #"<SW-VARIABLE>\s*<SHORT-NAME>([^<]*)</SHORT-NAME>.*<SW-ARRAYSIZE>\s*<VF>([^<]*)</VF>\s*</SW-ARRAYSIZE>.*?<(?:/(?!<SW-VARIABLE>)[^/]*?)SW-VARIABLE>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<SW-VARIABLE>
<SHORT-NAME>abc</SHORT-NAME>
<CATEGORY>VALUE</CATEGORY>
<SW-ARRAYSIZE>
<VF>4</VF>
</SW-ARRAYSIZE>
<SW-DATA-DEF-PROPS>
cde
</SW-DATA-DEF-PROPS>
</SW-VARIABLE>
<SW-VARIABLE>
<SHORT-NAME>def</SHORT-NAME>
<CATEGORY>VALUE</CATEGORY>
<SW-ARRAYSIZE>
<VF>8</VF>
</SW-ARRAYSIZE>
<SW-DATA-DEF-PROPS>
<HELLO>dsfadsf </HELLO>
<NO>itis</NO>
</SW-DATA-DEF-PROPS>
</SW-VARIABLE>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)