# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<SW-VARIABLE>\s*<SHORT-NAME>([^<]*)</SHORT-NAME>.*<SW-ARRAYSIZE>\s*<VF>([^<]*)</VF>\s*</SW-ARRAYSIZE>.*?<(?:/(?!<SW-VARIABLE>)[^/]*?)SW-VARIABLE>"
test_str = (" <SW-VARIABLE>\n"
" <SHORT-NAME>abc</SHORT-NAME>\n"
" <CATEGORY>VALUE</CATEGORY>\n"
" <SW-ARRAYSIZE>\n"
" <VF>4</VF>\n"
" </SW-ARRAYSIZE>\n"
" <SW-DATA-DEF-PROPS>\n"
" cde\n"
" </SW-DATA-DEF-PROPS>\n"
" </SW-VARIABLE>\n\n"
" <SW-VARIABLE>\n"
" <SHORT-NAME>def</SHORT-NAME>\n"
" <CATEGORY>VALUE</CATEGORY>\n"
" <SW-ARRAYSIZE>\n"
" <VF>8</VF>\n"
" </SW-ARRAYSIZE>\n"
" <SW-DATA-DEF-PROPS>\n"
" <HELLO>dsfadsf </HELLO>\n"
" <NO>itis</NO>\n"
" </SW-DATA-DEF-PROPS>\n"
" </SW-VARIABLE>")
matches = re.finditer(regex, test_str, re.DOTALL | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.