const regex = new RegExp('<SW-VARIABLE>\\s*<SHORT-NAME>([^<]*)</SHORT-NAME>.*<SW-ARRAYSIZE>\\s*<VF>([^<]*)</VF>\\s*</SW-ARRAYSIZE>.*?<(?:/(?!<SW-VARIABLE>)[^/]*?)SW-VARIABLE>', 'sgm')
const str = ` <SW-VARIABLE>
<SHORT-NAME>abc</SHORT-NAME>
<CATEGORY>VALUE</CATEGORY>
<SW-ARRAYSIZE>
<VF>4</VF>
</SW-ARRAYSIZE>
<SW-DATA-DEF-PROPS>
cde
</SW-DATA-DEF-PROPS>
</SW-VARIABLE>
<SW-VARIABLE>
<SHORT-NAME>def</SHORT-NAME>
<CATEGORY>VALUE</CATEGORY>
<SW-ARRAYSIZE>
<VF>8</VF>
</SW-ARRAYSIZE>
<SW-DATA-DEF-PROPS>
<HELLO>dsfadsf </HELLO>
<NO>itis</NO>
</SW-DATA-DEF-PROPS>
</SW-VARIABLE>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}