#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\(beta\)).*\(usa\)"
Local $sString = "Mario (usa).zip" & @CRLF & _
"Mario (usa) (beta).zip" & @CRLF & _
"Mario (beta) (usa).zip" & @CRLF & _
"Mario (japan).zip" & @CRLF & _
"Mario (usa) (japan).zip" & @CRLF & _
"Mario usa.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")