using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\(beta\)).*\(usa\)";
string input = @"Mario (usa).zip
Mario (usa) (beta).zip
Mario (beta) (usa).zip
Mario (japan).zip
Mario (usa) (japan).zip
Mario usa.zip";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}