import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\(beta\\)).*\\(usa\\)";
final String string = "Mario (usa).zip\n"
+ "Mario (usa) (beta).zip\n"
+ "Mario (beta) (usa).zip\n"
+ "Mario (japan).zip\n"
+ "Mario (usa) (japan).zip\n"
+ "Mario usa.zip";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}