$re = '/^(?!.*\(beta\)).*\(usa\)/m';
$str = 'Mario (usa).zip
Mario (usa) (beta).zip
Mario (beta) (usa).zip
Mario (japan).zip
Mario (usa) (japan).zip
Mario usa.zip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);