re = /^(?!.*\(beta\)).*\(usa\)/m
str = 'Mario (usa).zip
Mario (usa) (beta).zip
Mario (beta) (usa).zip
Mario (japan).zip
Mario (usa) (japan).zip
Mario usa.zip'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end