const regex = /^(?!.*\(beta\)).*\(usa\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\(beta\\)).*\\(usa\\)', 'gm')
const str = `Mario (usa).zip
Mario (usa) (beta).zip
Mario (beta) (usa).zip
Mario (japan).zip
Mario (usa) (japan).zip
Mario usa.zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}