#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^/(?:[^/\\0,\n]+/?)*$"
Local $sString = "/" & @CRLF & _
"/foo" & @CRLF & _
"/foo/bar/with/special/chars/a&b" & @CRLF & _
"/foo/with whitespace" & @CRLF & _
"name" & @CRLF & _
"name/subdir" & @CRLF & _
"/exception, due to ","" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")