re = /^\/(?:[^\/\\0,\n]+\/?)*$/im
str = '/
/foo
/foo/bar/with/special/chars/a&b
/foo/with whitespace
name
name/subdir
/exception, due to ","
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end