package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^/(?:[^/\\0,\n]+/?)*$`)
var str = `/
/foo
/foo/bar/with/special/chars/a&b
/foo/with whitespace
name
name/subdir
/exception, due to ","
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}