import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/(?:[^/\\\\0,\\n]+/?)*$";
final String string = "/\n"
+ "/foo\n"
+ "/foo/bar/with/special/chars/a&b\n"
+ "/foo/with whitespace\n"
+ "name\n"
+ "name/subdir\n"
+ "/exception, due to \",\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}