$re = '/^/(?:[^/\\\\0,\n]+/?)*$/im';
$str = '/
/foo
/foo/bar/with/special/chars/a&b
/foo/with whitespace
name
name/subdir
/exception, due to ","
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);