#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/post\/find\/)\d*\/{0}"
Local $sString = "/post/find/45" & @CRLF & _
"/post/find/4/abb" & @CRLF & _
"/post/find/044" & @CRLF & _
"/post/find/ab/45" & @CRLF & _
"/post/find/34/44" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")