// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\/post\/find\/)\d*\/{0}").unwrap();
let string = "/post/find/45
/post/find/4/abb
/post/find/044
/post/find/ab/45
/post/find/34/44
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}