using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/post\/find\/)\d*\/{0}";
string input = @"/post/find/45
/post/find/4/abb
/post/find/044
/post/find/ab/45
/post/find/34/44
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}